Учебник по 1С


Чтение файла DBF


В данном случае, мне кажется, что проще написать программу и прокомментировать ее, чем делать что-то еще. Вы уже такие продвинутые, раз добрались до этой главы! Я горжусь вами!

Файл = создатьОбъект("XBASE"); //создаем ссылку на файл DBF

Файл.ОткрытьФайл("catalog.dbf"); //открываем файл на диске

Файл.КодоваяСтраница(1); //задаем кодировку: 0 - windows, 1 - DOS

Если Файл.Открыта()=0 Тогда //проверяем, удалось ли открыть файл

........Сообщить("Не удалось открыть файл!");

КонецЕсли;

Файл.Первая(); //позиционируемся на первой записи

Пока Файл.ВКонце()=0 Цикл //пока не дошли до конца, крутим цикл

.......НомерЗаписи = Файл.НомерЗаписи(); //получаем номер текущей записи

.......НазвТовара = Файл.NAME; //получаем значение поля

.......Цена = Файл.ПолучитьЗначениеПоля("PRICE"); //так тоже можно, но чуть медленнее

.......Файл.Следующая(); //переходим на следующую запись

КонецЦикла;

Файл.Последняя(); //позиционируемся на первой записи

Пока Файл.ВНачале()=0 Цикл //пока не дошли до начала, крутим цикл

.......НазвТовара = Файл.NAME;

.......Цена = Файл.PRICE;

.......Файл. Предыдущая(); //переходим на предыдущую запись

КонецЦикла;

Для н = 1 По Файл.КоличествоЗаписей() Цикл //здесь все понятно, по-моему

......Файл.Перейти(н); //позиционируемся на определенной записи

.......НазвТовара = Файл.NAME;

.......Цена = Файл.PRICE;

КонецЦикла;


Файл.ЗакрытьФайл(); //не забывайте пожалуйста




- Начало -  - Назад -  - Вперед -